Difference between revisions of "Axidraw Software Installation"

From Evil Mad Scientist Wiki
Jump to: navigation, search
 
Line 13: Line 13:
  
  
=== Quick install ===
+
=== Quick install (macOS 10.7 - 10.14) ===
  
 
:1. Download and open the [https://github.com/evil-mad/axidraw/releases/download/v2.5.3/AxiDraw_v253_r2_Mac.dmg AxiDraw Mac bundle DMG]
 
:1. Download and open the [https://github.com/evil-mad/axidraw/releases/download/v2.5.3/AxiDraw_v253_r2_Mac.dmg AxiDraw Mac bundle DMG]
Line 24: Line 24:
  
  
=== Alternative (Manual) install ===
+
=== Alternative (Manual) install for macOS 10.7 - 10.14 ===
  
 
:If you already have XQuartz and Inkscape 0.92 installed on your computer, or cannot run the quick installer for some reason, you can also install the AxiDraw extensions alone.  
 
:If you already have XQuartz and Inkscape 0.92 installed on your computer, or cannot run the quick installer for some reason, you can also install the AxiDraw extensions alone.  

Latest revision as of 10:00, 5 November 2019

  This wiki page is part of our AxiDraw documentation

Please click here to return to the AxiDraw overview.

AxiDraw is designed to work well on Mac, Windows, and Linux computers. To use it, you'll need to install certain software on your computer. Please read below for specific instructions for Mac, Windows, and Linux.

The current software version is v. 2.5.3, released June 24, 2019.

Mac[edit]

For macOS Catalina (10.15)[edit]

If you are using a Mac (MacOS Catalina 10.15 -- released October 7, 2019), please contact technical support for special installation instructions. We will be posting special installers for Catalina in the near future.


Quick install (macOS 10.7 - 10.14)[edit]

1. Download and open the AxiDraw Mac bundle DMG
2. Run the XQuartz installer included in that DMG (disk image) file.
3. Drag the included copy of Inkscape to your "Applications" folder.
4. Eject the disk image (DMG).


Alternative (Manual) install for macOS 10.7 - 10.14[edit]

If you already have XQuartz and Inkscape 0.92 installed on your computer, or cannot run the quick installer for some reason, you can also install the AxiDraw extensions alone.
1. Prerequisites: Download and install XQuartz and Inkscape 0.92.2
2. Download the AxiDraw software in this ZIP archive (0.4 MB), and unzip it.
3. In the finder, open a new window (File > New Finder Window) and then select Go > Go to Folder...
4. Paste the following folder location into the dialog box:
/Applications/Inkscape.app/Contents/Resources/share/inkscape/extensions/
and click the "Go" button to open that location. This is your "Inkscape extensions" folder.
5. Copy the contents of the ZIP archive that you downloaded (22 items total; 20 files and two folders) into your Inkscape extensions folder, overwriting any files with the same names.
6. Launch (or quit and re-launch) Inkscape.
  • The "AxiDraw" submenu should appear in the Extensions menu of Inkscape after you restart Inkscape.


For Older MacOS versions (older than 10.7)[edit]

The instructions above are for MacOS 10.7 and newer. Please contact technical support if you need to install AxiDraw software on an older Mac.


Troubleshooting[edit]

Your software should now be set up to work correctly.
  • Because Inkscape runs on X11's architecture, keyboard shortcuts use control (^) instead of Cmd (⌘) as modifier key.
  • If copy and paste are not working correctly in Inkscape, open the X11 preferences dialog, and disable the "Update Pasteboard when CLIPBOARD changes" option.
  • If you encounter difficulty installing the AxiDraw extensions for Inkscape (or with plotting, in the next stage), please request assistance through our contact form or through the AxiDraw forum.
  • If there is any chance that a problem you encounter is specific to AxiDraw software or hardware, it is important that you do not directly seek assistance through Inkscape's support resources. You're much more likely to get your problem solved by asking people who know about AxiDraw. And, we'd like the Inkscape team to be ready to help us when we do encounter Inkscape-specific issues.


Windows[edit]

Installation[edit]

1. Download and install Inkscape version 0.92.4 from the download page at Inkscape.org. (Most users will want the 64-Bit download.)
  • Install Inkscape in the default location, the main "Program Files" folder.
  • If you need additional assistance for installing Inkscape, you may be able to find good advice at the the Inkscape wiki and/or the Inkscape Forums. Please do not use Inkscape support resources for AxiDraw-specific issues-- see note below about troubleshooting.


2. Download and run the AxiDraw installer for Windows: Download link (0.6 MB)
  • The installer is an executable, named "AxiDraw_253_r4.exe".
  • After running the installer, launch (or restart) Inkscape. The "AxiDraw" submenu should appear in the Extensions menu.


Alternative (Manual) install[edit]

If you already have Inkscape 0.92.4 installed on your computer, you can also install the AxiDraw extensions alone. For Windows 8 and older versions, please use the installer above for the first time that you install AxiDraw software, as the installer also includes a necessary USB driver. (You can use the manual method for subsequent installs and upgrades, and for Windows 10, which does not require the USB driver.)
1. Download the software in this ZIP archive (0.4 MB), and unzip it. (Your computer may unzip the archive automatically for you.)
2. Locate and open your Inkscape extensions directory. Your extensions directory is usually located at:
C:\Program Files\Inkscape\share\extensions\
or possibly
C:\Program Files (x86)\Inkscape\share\extensions\
3. Copy the contents of the ZIP archive that you downloaded (22 items total; 20 files and two subdirectories) into your Inkscape extensions directory, overwriting any files and directories with the same names.
4. Launch (or quit and re-launch) Inkscape.


Troubleshooting[edit]

Your software should now be set up to work correctly.
  • If you encounter difficulty installing the AxiDraw extensions for Inkscape (or with plotting, in the next stage), please request assistance through the AxiDraw mailing list or forum, which you can find on our front page.
  • If there is any chance that a problem you encounter is specific to AxiDraw software or hardware, it is important that you do not directly seek assistance through Inkscape's support resources. You're much more likely to get your problem solved by asking people who know about AxiDraw. And, we'd like the Inkscape team to be ready to help us when we do encounter Inkscape-specific issues.


Linux[edit]

The AxiDraw extension for Inkscape has been developed and tested extensively under Ubuntu. We expect it to work equally well in most Ubuntu derivatives and other distributions where Inkscape is known to work. However, we do not have the capability to test every distribution. If you are unsure if your distribution will work, try to install Inkscape, and see if it appears to launch and run correctly. (We do also have python-based command-line tools available to run the AxiDraw, even on systems where Inkscape is not supported.)


  • Install Inkscape 0.92 on your computer. The best way to do this will vary by distribution, but in most cases you can use the software installer provided with the OS. See here for additional information.
  • Launch Inkscape, and select Edit > Preferences from the menu, and then select the System entry. That should list the location of your User extensions directory.
  • With a "Snap" distribution of Inkscape, that location might be something like ~/snap/inkscape/4274/extensions/
  • Download and unzip the software in this ZIP archive . Copy its contents into your Inkscape User extensions directory and relaunch Inkscape.


About adding your user account to the "dialout" group:

In modern Linux releases, it is often necessary to change your user permissions, to explicitly grant access to the USB port where the AxiDraw is located. This can be done by adding your user group to the "dialout" user group on your system.
  • Open up a terminal window
  • For most distributions (including Fedora and Ubuntu), enter the command "sudo usermod -a -G dialout <myUserName>" <return>, replacing the <myUserName> part with the user that is running Inkscape (and without the quotation marks or angle brackets!).
  • If you are unsure of your user name, enter the command "whoami" <return>, and the computer will happily remind you.
  • If you are unsure whether you are already in the "dialup" group, enter the command "groups" <return>, and the computer will list the groups that you are in.
  • After changing groups, you need to log out and log back in for the change to take effect.


sudo usermod -a -G dialout <myUserName>"

Debian Wheezy install instructions(command line):

  • Download the latest Inkscape extension .ZIP file from the downloads section of the AxiDraw Releases page.
  • Open up a terminal window, enter the command ,<return>, where you type your user name instead of UserName (And, no quotation marks.):
"sudo apt-get install inkscape"
"sudo apt-get install unzip python-lxml"
unzip the latest Inkscape extension .ZIP file into 
/home/'UserName'/.config/inkscape/extensions

Than you can use the AxiDraw extension for Inkscape by type: "inkscape" <return>

Troubleshooting

If your permissions are not correct (your user is not in the dialout group), you may get consistent "Unable to find an AxiDraw" type error messages.
If the AxiDraw menu doesn't appear in Inkscape, verify that when you've extract the zip file, all the .py files are inside .config/inkscape/extensions/ folder (you might have extracted the entire AxiDraw folder, and .py files might be misplaced)



Firmware Update[edit]

We encourage all AxiDraw users to update the latest firmware version, which is "EBB" firmware version 2.6.2. Once your AxiDraw software is up and running, you can check which version of the firmware you have by selecting the "Config" tab of AxiDraw Control and clicking Apply.

EBB Firmware versions 2.4.6 and newer contain performance improvements and bug fixes that can prevent certain types of errors.

To update your firmware, please follow the directions here.