AxiDraw トラブルシューティング

From Evil Mad Scientist Wiki
Jump to: navigation, search

  This wiki page is part of our AxiDraw documentation

Please click here to return to the AxiDraw overview.
  ※ このページは公式のものではなく、日本人の有志ユーザーが作成していますので、公式の見解ではありません。

※ 内容の一部もしくは全部に、間違いがある可能性があります。



プロッター出力はできるけど、問題があります[edit]

線がハネたり、かすれてしまいます[edit]

ペンの高さの調節
想定しないところで線がハネて繋がったり、薄くかすれてしまうのは、多くの場合「ペンの高さ」があっていないのが原因です。
ペンをセットしたら、[Setup]タブでペンの高さを調節して、ペンダウンした時に「用紙より1~3mmくらい下」になるよう調節してください。ペン自体を調節しても良いですし、[Setup]タブの「Down値」を調節しても構いません。
プロットの速さの調節
プロット速度が速すぎると、文字がかすれたり、ペンが上がりきる前に移動するため、線がハネてしまう場合があります。
[Timing]タブの「Writing/Drawing speed」を、10~20くらいに設定してみてください。
それでも、文字にハネが発生するようなら、「Pen-up movement speed」の値を、80~90くらいにしてください。
用紙の反り
用紙や土台などが反っていたり、歪んでいたりしませんか?
それによりペンの高さが一定にならなくなると、線がハネたりします。


線がにじんでしまいます[edit]

ペンを変えてみる
ペンがにじむ原因の一つとして、ペンの種類を変えてみることをオススメします。水性ペンは滲みやすいので、油性ペンに変えてみるのが良いでしょう。
紙を変えてみる
紙の素材を変えることで、ペンの滲みを抑えることが可能です。可能であれば検討してみましょう。
ペンの高さ
線の最初と最後が滲んでしまう場合には、ペンの高さの設定を変えてみましょう。ペンが接地する時間が長いほど、にじみが大きくなります。できるだけギリギリに接地して、高い位置にペンアップするようにして、ペンの動作も早めにすることで、ペンのにじみを最小限にすることができます。


横方向に印刷されてしまいます[edit]

AxiDraw V3が「A4までしか出力できない」ため、90度回転した状態がデフォルトになっています。
まっすぐな方向にプロッター出力したい場合には、「AxiDrawコントロール」の [オプション]タブの、「Auto-rotate page when printing」のチェックを外す必要があります。
AxiDraw V3 / A3や、AxiDraw V3 / SE などを利用している場合には、外しておいたほうが良いでしょう。


プロッター出力できません[edit]

プロッター出力できず、エラー画面が表示されない場合です。
基本的なポイントの見落としの場合が、大半だと思います。
下記をすべてチェックしてみて、それでも駄目だった場合には、本体の故障や初期不良、ソフトの不具合の可能性があります。

基本的なチェック項目[edit]

電源ケーブル、USBケーブルが接続されているか、チェックしてください。
本体の前面に、赤ランプが点灯していないかチェックしてください。
Inkscapeを再起動してみてください。
AxiDraw本体の電源ケーブル、USBケーブルを両方抜いて、10秒ほどしてから接続してみてください。


上記でも駄目な場合[edit]

「プレビューモード」になっていないか、[オプション]タブを確認してください。
パソコンを再起動してください。
ソフトの再ダウンロード・再インストールを試してみてください。


Inkscapeでプロッター出力できず、エラー表示されます[edit]

「ドキュメントのプロパティー」の設定ミス[edit]

Adobe Illustratorで作成した「ファイル」を開いた際などに、下記のエラーが出る場合があります。
  • This document does not have valid dimensions.
  • The document dimensions must be in either millimeters (mm) or inches (in).
  • Consider starting with the Letter landscape or the A4 landscape template.
  • Document dimensions may also be set in Inkscape,
  • using File > Document Properties.
  • この文書は「有効な寸法」を持っていません。
  • 文書の寸法は、ミリメートル(mm)またはインチ(in)のいずれかにする必要があります。
  • Letterサイズ(横向き)から始めることを検討してください。A4用紙(横向き)テンプレートを推奨。
  • 文書の寸法は、Inkscapeでも設定できます。
  • メニューの [ファイル] > [ドキュメントのプロパティー]
【解決方法】
Inkscapeのメニューの [ファイル] > [ドキュメントのプロパティー]を選択。
たとえばA4サイズなら、ページサイズを「A4」に設定してください。
このページサイズの一覧にないサイズの用紙に出力したい場合には、カスタムサイズに「任意の数値」を入力して指定してください。その際、デフォルトの「px」単位のままだとエラーが出るので、「mm」単位に変更する必要があります。


「使用機種」の設定ミス[edit]

AxiDraw V3 / A3 を利用中に、「AxiDrawコントローラー」の[Version]タブで、AxiDraw V2/AxiDraw V3を選択していると、このエラーが発生しました。これにより、縦幅は正しく印刷され、縦幅のみが短くプロッター出力されました。(印刷向きをオフにしている場合)
AxiDrawの出力範囲以上のサイズを出力しようとした際に、起こるのかもしれません。(未検証)
  • Warning: AxiDraw movement was limited by its physical range of motion.
  • If everything looks right, your document may have an error with its units or scaling.
  • Contact technical support for help.
  • 警告:AxiDrawの動きは、その物理的な動きの範囲によって制限されていました。
  • すべてが正しく見えていれば、あなたの文書はその単位やスケールに誤りがあるかもしれません。
  • テクニカルサポートに連絡してください。
【解決方法】
「AxiDrawコントローラー」の[Version]タブで、使用している機種名を選択して、更新してください。


SVGファイルの出力時のエラー[edit]

Adobe Illustratorで作成したSVGファイルを出力しようとすると、下記のようなエラー画面が表示される。
  • Warning: unable to plot <switch> object
  • found in file. Please convert it to a path first.
  • Warning: unable to plot <pgf> object
  • found in file. Please convert it to a path first.
  • 警告:<switch>オブジェクトをプロットできません
  • ファイルで見つかりました。まずパスに変換してください。
  • 警告:<pgf>オブジェクトをプロットできません
  • ファイルで見つかりました。まずパスに変換してください。
【解決方法】
SVG形式を使わず、Illustrator形式(.aiファイル)で保存して、そのファイルをIncscapeで開いて、プロッター出力する。

その他のトラブル[edit]

Inkscapeに画像をインポートすると大きくなるのはなぜ?[edit]

詳細については、Incscape 公式Wiki トラブルシューティング をご覧ください。
> Inkscapeのビットマップ画像 (JPEG、PNG、TIFFなど) のインポートには制限事項があり、その解像度を読み込むことができません。インポートされた画像はすべて90dpi(新バージョンでは96dpi)であるとみなされ、解像度が異なる画像はそのために大きくなったり小さくなったりして表示されます。例えば、180dpiで作成された画像をインポートすると、Inkscape上では絶対単位で2倍の大きさ (180 = 90 × 2) になります。これは画像のピクセルそのものが拡大縮小されるだけで、どこかにピクセルの追加や削除が発生するわけではないことを覚えておいてください。
(まだ未検証ですが……)縦2000px 横1000px 解像度72dpiで作成したファイルをIncscapeにインポートすると、Incscapeでは強制的に96dpiに変更されてしまうため、縦横が1.3333…倍になり縦2666px 横1333pxになります。これを避けるには、フォトショップ/イラストレーター上で96dpiで作成して、ファイルを読み込むようにすれば回避できると思います。

問題点の切り分け[edit]

プロッター出力できない場合に「問題点の切り分け」をしていくために、下記を一つずつ試してみてください。
【有志ユーザーによる検証済み】(Windows10環境、Adobe Creative Cloud、2019年5月検証)

AxiDrawの状態を確認する[edit]

  • AxiDraw本体に、USBケーブルと電源ケーブルは接続していますか?
  • 本体にUSBケーブルを接続したときに、反応しましたか?(PCスピーカーから音は鳴ったか?)
  • AxiDraw本体の左側にある、LEDを確認してください。
  • 通常、「緑色のランプ」が点滅しています。(2回点滅して休みの繰り返し)
  • 「赤色のランプ」が点滅していたら、電源ケーブルとUSBケーブルを入れ直してください。
  • ※ 横側のランプは、赤色なのは問題ありません。電源ケーブル接続部のLEDを見てください。

AxiDrawの動作を確認する[edit]

  • Inkscapeを起動し、[エクステンション]タブ > [AxiDrawコントロール]を開く。
  • [Setup]タブで、「Toggle pen between Up,Down」を選択して、適用を押す。(本体が動作しましたか?)
  • [Manual]タブで、[Command]オプションを任意に設定して、「適用」を押す。(本体が動作しましたか?)

サンプルファイルを出力してみる[edit]

  • サンプルファイルをダウンロードして、ZIPファイルを解凍する。
  • Inkspaveで、SVGファイルを開く。(ファイルをドロップしてもOK)
  • [エクステンション]タブ > [AxiDrawコントロール]で「適用」をクリックする。


ここまでが問題なく出来ていれば、おそらく「AxiDraw本体」の問題ではありません。
「Inkscape」「AxiDrawコントローラー」のソフトウェアも、おそらく正常に動作しています。
あなたが制作している「作品データ」に、なんらかの問題がある可能性が高いと思われます。
一つの可能性として、「ファイル形式」に原因があります。(下記のとおり、ai形式ファイルを試してください)


Inkscapeで簡単に制作してみる[edit]

  • Inkscape
  • Inkscapeで、[ファイル] >「新規ファイル」を作成する。
  • Inkscapeの「ペンツール」を使って、簡単にパスを作成する。
  • [エクステンション]タブ > [AxiDrawコントロール]で「適用」をクリックする。

Illustratorで保存したファイルを試す[edit]

  • Illustrator
  • Illustratorで、[ファイル] >「新規ファイル」を作成する。
  • Illustratorの「ペンツール」を使って、簡単にパスを作成する。
  • [ファイル] > 「別名で保存」で「Adobe Illustrator形式(.ai)」に保存する。
  • 「PDF互換ファイルを作成」にチェックを入れる。(他のオプションは任意)
  • Inkscape
  • Inkscapeで、[ファイル] >「開く」で、先程のファイルを開く。
  • Inkscapeの「ペンツール」を使って、簡単にパスを作成する。
  • [エクステンション]タブ > [AxiDrawコントロール]で「適用」をクリックする。

Photoshopで保存したファイルを試す[edit]

  • Photoshop
  • Photoshopで、[ファイル] >「新規ファイル」を作成する。
  • Photoshopの「ペンツール」を使って、簡単にパスを作成する。
  • [ファイル] > 「書き出し」で「Illustratorへのパス書き出し」をする。
  • Illustrator
  • Illustratorで、[ファイル] >「開く」で、先程のファイルを開く。
  • パスに色がついていない場合には、Ctr+Aを押してパス選択して、[カラー]ウインドウで任意の色をつける。
  • [ファイル] > 「別名で保存」で「Adobe Illustrator形式(.ai)」に保存する。
  • 「PDF互換ファイルを作成」にチェックを入れる。(他のオプションは任意)
  • Inkscape
  • Inkscapeで、[ファイル] >「開く」で、先程のファイルを開く。
  • Inkscapeの「ペンツール」を使って、簡単にパスを作成する。
  • [エクステンション]タブ > [AxiDrawコントロール]で「適用」をクリックする。


おそらく、ここまでの内容を活用すれば、基本的なプロッター出力は問題ないと思います。
問題が生じている場合には、文章をよく読んで、「読み間違い」「勘違い」がないかチェックしましょう。


Illustratorで保存したSVGファイルを出力する方法 (情報募集)[edit]

この記事を書いているAxiDrawユーザーの筆者の環境では、Illustratorで保存したSVGファイルを、Inkscapeで開いてプロット出力すると、エラーが出てしまいます。公式のサンプルファイルのSVGファイルは、問題なくプロッター出力できます。
仕方なく、上記のようにaiファイル形式で試したところ、なんの問題なく利用できています。SVGファイルで利用する方法をご存知の方がいましたら、ぜひ情報を教えてもらえると助かります。

SVG形式で保存する場合
Adobe IllustratorまたはCorelDRAWから、SVG形式でグラフィックを保存する場合に役に立つヒントとして、SVGエクスポートオプションで「プレゼンテーション属性」オプションを選択することです。 これは通常、Inkscapeで書式設定をより良く機能させるのに役立ちます。

関連項目 [edit]

AxiDraw 日本語トップページ
導入ガイド ユーザーガイド V3
ユーザーガイドのダウンロード (英語) - ソフトウェアのインストール (英語)
ヒント ペンの選択 (英語) - マルチカラー出力 (英語) - 画像をトレースする (英語) - 点描ソフトウェア (英語) - レイヤー管理 (英語) - 手書きのキャプチャー (英語) - RoboPaintでAxiDrawを使う - AxiDraw基本例セット
Q&A よくある質問 - トラブルシューティング
外部リンク 公式サイト - 公式ショップ - ロボショップ - RakuNewショップ - docket store - ゆきの散歩道 - マルチカラー出力 - Youtube動画
その他 テンプレートを編集